+420 774 447 953   info@mydreams.cz
Košík je prázdný

FAQ: Proč nejede web na PHP 7.2?

Klienti mají nyní možnost na nových webhosting serverech zvolit verze PHP 5.4 nebo 7.2. Verze PHP 5.4. je stabilní, stará a osvědčená, a verze PHP 7.2. je nová a 2x rychlejší ALE! Obrací se na nás klienti s problémy funkčností webů po přechodu na PHP 7.2.

Některé funkce ve verzích PHP 5.4. a 5.6. jsou zastaralé (deprecated) a tak jsou logicky ve verzi PHP 7.2 už odstraněny. Jedná se především o redakční systémy, které používají pro připojení k databázi funkce mysql, které jsou nyní ukončeny. Redakční systémy stačí pouze aktualizovat a přepnout připojení k databázi na mySQLi nebo PDO.

Pro weby bez redakčních systémů jsou důležité následujicí změny:

  • Odebrání funkce mysql_* Nově používat mysqli, nebo lépe PDO.
  • Odebrání funkce mssql_*
  • Odebrání funkce ereg_
  • Odebrání funkce set_magic_quotes_runtime
  • Odebrání funkcí mcrypt_ecb, mcrypt_cbc, mcrypt_cfb, mcrypt_ofb
  • Odebrání funkce preg_replace()
  • A mnoho dalších https://wiki.php.net/rfc/remove_deprecated_functionality_in_php7